[Tool] Minge: The CarMODgeddon Mod Installer

The 2016 reincarnation of Carmageddon! Discuss, mod and troubleshoot!
User avatar
starbuck
kill boss
Posts: 1604
Joined: Wed Jan 21, 2004 12:26 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by starbuck »

Whats weird is that I swore I could have ZADs in my Carmodgeddon folder in steam. I just started up the new Minge to test it and the ZAD files turned to ZIP files automatically.

Dont know if its the cold medicine talking though :)

EDT temporarily changed them by hand to ZAD restarted Minge again and it DID changed them back to ZIP. Cool !
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

Yes automatic renaming of ZAD to ZIP so installed mods work with the games latest update is a feature of the new version of Minge. Weirdly enough it is mentioned in the readme.txt's change log and my post above :)
a.k.a. Brent
User avatar
starbuck
kill boss
Posts: 1604
Joined: Wed Jan 21, 2004 12:26 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by starbuck »

On serious cold medication all day :)

Oh hell I said that already .
User avatar
timmy76
motorised death
Posts: 825
Joined: Mon Oct 01, 2007 5:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by timmy76 »

Mine keeps coming up like and won't let me drag in a .zad file.


Also crashes when i try to press save

copied the error it puts under detail


Spoiler:


See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.IO.FileNotFoundException: Could not load file or assembly 'System.IO.Compression, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

File name: 'System.IO.Compression, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

at Minge.MingeForm.SaveCarmodgeddonLUA()

at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ButtonBase.WndProc(Message& m)

at System.Windows.Forms.Button.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

Minge

Assembly Version: 1.0.0.0

Win32 Version: 1.0.0.0

CodeBase: file:///C:/Users/Jim/Desktop/Minge/Minge.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 built by: RTMRel

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 built by: RTMRel

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 built by: RTMRel

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 built by: RTMRel

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.1 built by: RTMRel

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------


************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.


For example:



When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.



User avatar
shane
Stainless
Posts: 1080
Joined: Sun May 22, 2011 11:00 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by shane »

Nice work Trent on getting this new update out so quick to comply with our new updates! Much appreciated!

Happy modding guys!
Ex-Carmageddon Community Manager - Carmageddon.com
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

timmy76 wrote:Mine keeps coming up like and won't let me drag in a .zad file.


Also crashes when i try to press save

copied the error it puts under detail
Try running Minge as administrator and see if that helps. It could be a permissions issue stopping it from writing to the game's directory as it's in Program Files.
a.k.a. Brent
User avatar
timmy76
motorised death
Posts: 825
Joined: Mon Oct 01, 2007 5:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by timmy76 »

Yeah first thing I did was run as admin.
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

Has it created the CarMODgeddon folder structure in your C:R folder?
a.k.a. Brent
User avatar
timmy76
motorised death
Posts: 825
Joined: Mon Oct 01, 2007 5:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by timmy76 »

Yeah it created a CarMODgeddon folder but won't let me add any mods as described.
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

Hmm, just scanned through that error log, do you have .NET 4.5 installed or just 4? Minge uses the ZIP compression features of 4.5 so if you've only got 4 installed you need to install the update to .NET to use it.

For the next version I might see about swapping the ZIP handling to us Errol's ZAD classes instead and try compiling the tool for .NET 4 but most people should install 4.5 anyway so it's probably not worth while.
a.k.a. Brent
User avatar
coffeycup
Genesis
Posts: 4811
Joined: Sun Sep 27, 1998 6:00 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by coffeycup »

I've just repacked my BeerWagon mod but for some reason I'm having a problem with the ui_assets. Oddly the larger default_top view shows ingame but the default_minimap and default_side do not?? There's just an empty space.

I even went back to the original PNGs and used Flummery to convert to TDX then repacked ui_assets to get new IMGs. NOTE:The Red Baron's ui_assets show fine. They were not repacked just renamed to ZIP via Minge.
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

Hmm, that is odd, CoffeyCup. It should be packing all the ui_assets TDX files normally, it no longer needs to convert any textures to IMG. When you open up the ZIP in your favourite ZIP utility, which files does it list in the [CarName]\ui_assets\ path?
a.k.a. Brent
User avatar
coffeycup
Genesis
Posts: 4811
Joined: Sun Sep 27, 1998 6:00 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by coffeycup »

Oh, you're right there are no IMGs now. Just a PNG and TDX for top, side and minimap. Six total.
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

If the TDX files are in the ZIP then they should work, which leads me to think it's more likely a problem with the specific TDX files rather than with Minge. I assume the files are correctly named (e.g. [CarName]_default_minimap.tdx)? Could you try using GibbedTools to convert the TDX files back to PNG and see if they convert okay?
a.k.a. Brent
User avatar
timmy76
motorised death
Posts: 825
Joined: Mon Oct 01, 2007 5:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by timmy76 »

That fixed it Trent

Thought I had .NEtT4.5 installed but remembered my pc had to rebuilt 3 months ago.
User avatar
coffeycup
Genesis
Posts: 4811
Joined: Sun Sep 27, 1998 6:00 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by coffeycup »

I guess the updated game still uses IMGs for the MiniMap and some menu screens. I finally got my Beer Wagon minimap and side view icons to appear once I checked off "Convert Textures to IMG" when packing them up.
User avatar
Mad Mike
road raged psycho
Posts: 1233
Joined: Wed Aug 03, 2011 8:30 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Mad Mike »

I guess the updated game still uses IMGs for the MiniMap and some menu screens. I finally got my Beer Wagon minimap and side view icons to appear once I checked off "Convert Textures to IMG" when packing them up.
All of my UI assets are working fine as TDX. Have you tried re-converting the PNGs to TDX manually with GibbedTools?

You said earlier that it was just showing a white space? If so, then it's failing to load the texture for some reason. If the texture was 'missing' completely, then it would use the Generic Car & Eagle Assets.
One man... Alone... Wrecking opponents in the Automobile he loves.
Twitter Manifestation. - Mods for Max Damage.
User avatar
coffeycup
Genesis
Posts: 4811
Joined: Sun Sep 27, 1998 6:00 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by coffeycup »

I've been using Flummery's TDX converter on the PNGs. Didn't any problem with them until the update. But as long as checking off the 'Convert Textures to IMGs' works then I'm ok with that.
User avatar
Errol
Toxic Ranger
Posts: 1160
Joined: Wed Apr 05, 2000 12:16 pm
Location: Sunny Wales

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Errol »

Coffey, could you drop me a link to the PNGs you're trying to convert that weren't working? If I have a bug in my code that'll help me track it down.
User avatar
coffeycup
Genesis
Posts: 4811
Joined: Sun Sep 27, 1998 6:00 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by coffeycup »

Sure thing. Here's all three PNGs The two 180x90 for minimap and side view aren't appearing. But the 720x360 larger top view does show up when as a TDX.
User avatar
Deadhart
motorised death
Posts: 935
Joined: Fri Jun 03, 2011 5:48 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Deadhart »

Can I get some help please? I get this error when running Minge v2 and It refuses to register any mods, here's the exact text of the error:

Unhandled exception has occured in your application. If you click Continue, the appllication will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

Input string was not in a correct format.

With the options Details, Continue and Quit availible. When Details is sselected, this comes up.:

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.


************** Exception Text **************

System.FormatException: Input string was not in a correct format.

at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)

at System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)

at Minge.MingeForm.wc_DownloadStringCompleted(Object sender, DownloadStringCompletedEventArgs e)

I was trying to install Mad Mike's Used Cars when this happened, it was my first brush with Minge as well.

EDIT: Well now it loads mods, I noticed the v2.5 updtate and it works. But for some reason the error still stands, if the thing gets mods ingame right though, it's not worth noticing.
User avatar
Big_pimouss
pedestrian
Posts: 24
Joined: Fri Jan 30, 2015 11:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Big_pimouss »

The same here ! I cannot install any mods ... ( .net is update )
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

I'll look into these issues for the next version. I'm planning on adding launcher features to the next version of Minge so you can launch the game directly into CarMODgeddon mode, turn on error logging and force the game to use extracted data.

Other planned features are:

Config editing & presets - Create different configs for modding and playing, so when you make mods you can run the game windowed at a lower resolution while running the game full screen at full resolution for actual gameplay. Other uses would be test your cars out at various detail settings

Mod Packages - The ability for multiple mods to be installed as a package rather than individually. E.g. rather than having to select each C1 car and each C1 wheel to install, just select the Carma1Cars.mingebag file to install the lot.

ZADFucker integration - extract the game's data from within Minge without having to faff around with other software

LOLDecoder integration - further to the ZADFucker integration, it will let Minge decoder all the LOL scripts in one go instead of having to do them individually.
a.k.a. Brent
User avatar
Big_pimouss
pedestrian
Posts: 24
Joined: Fri Jan 30, 2015 11:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Big_pimouss »

Cool !
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

a.k.a. Brent
User avatar
MrDeviance
turbo bastard
Posts: 419
Joined: Wed May 28, 2014 7:30 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by MrDeviance »

What a bunch of great mixed together tools you're doing here.

I really appreciate your work at fusing all of these tools under one roof and making it hassle free and noob friendly.

This is what truly helps grow the modding community for those that are noobs or just can't be assed to go through 100 different tutorials on how to get various mods installed.

I think there are 3 people in this community that are still managing to keep this game alive for me.

The prospect of unifying all the previous carmageddon games into the current one, is really a thing that keeps me hoping.

The other factor that keeps me interested, is tied to the awesome cars that AlexTSK is doing with all those detailed interiors.

I guess the prospect of even further optimizing the game and updating it with more cars and features, is also a something to look forward to.
User avatar
RiOrus
turbo bastard
Posts: 374
Joined: Thu Jun 02, 2011 7:49 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by RiOrus »

You know what? It's good to see a positive post from you mrdeviance, you get a lot of stick for being coarse when it comes to your 'constructive critism' as you put it but you are spot on with this. It's obvious there are a few souls doing good things for the community. I just wish I had the free time to even implement some of the mods, let alone learn how to create some. I'm loving alextsk's cleaver redux. Looks so good. The fact that it's the modders keeping the forums ticking over proves the value of their support. It's why I rarely post anymore, don't have anything meaningful to contribute to the convos. Waiting excitedly for additional content.
User avatar
Steelmaniac
pedestrian
Posts: 2
Joined: Wed Jan 06, 2016 9:59 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Steelmaniac »

Been running into a bit of a problem when trying to launch minge. Tells me the program stopped working, even on admin mode.

Any suggestions?
User avatar
starbuck
kill boss
Posts: 1604
Joined: Wed Jan 21, 2004 12:26 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by starbuck »

Steelmaniac wrote:Been running into a bit of a problem when trying to launch minge. Tells me the program stopped working, even on admin mode.

Any suggestions?
I think you need NET 4.5 installed. It would also help if you posted your operating system and other details. Plus make sure you have the latest version of Minge.
User avatar
AlexTSK
mindless
Posts: 2858
Joined: Sun Dec 18, 2011 1:12 pm
Location: South Africa

[Tool] Minge: The CarMODgeddon Mod Installer

Post by AlexTSK »

Also specify if you've used it before or have any old mods installed etc
User avatar
Big_pimouss
pedestrian
Posts: 24
Joined: Fri Jan 30, 2015 11:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Big_pimouss »

I show you the error i have ( sorry ,I'm French )

************** Texte de l'exception **************

System.FormatException: Le format de la chaîne d'entrée est incorrect.

à System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)

à System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)

à Minge.MingeForm.wc_DownloadStringCompleted(Object sender, DownloadStringCompletedEventArgs e)

à System.Net.WebClient.OnDownloadStringCompleted(DownloadStringCompletedEventArgs e)

************** Assemblys chargés **************

mscorlib

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

Minge

Version de l'assembly : 1.0.0.0

Version Win32 : 1.0.0.0

CodeBase : file:///D:/Steam/steamapps/common/Vehicule%20Carma/Minge/Minge.exe

----------------------------------------

System.Windows.Forms

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Configuration

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Core

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

System.Xml

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.IO.Compression.FileSystem

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.IO.Compression.FileSystem/v4.0_4.0.0.0__b77a5c561934e089/System.IO.Compression.FileSystem.dll

----------------------------------------

System.IO.Compression

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.IO.Compression/v4.0_4.0.0.0__b77a5c561934e089/System.IO.Compression.dll

----------------------------------------

System.Windows.Forms.resources

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_fr_b77a5c561934e089/System.Windows.Forms.resources.dll

----------------------------------------

mscorlib.resources

Version de l'assembly : 4.0.0.0

Version Win32 : 4.6.81.0 built by: NETFXREL2

CodeBase : file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_fr_b77a5c561934e089/mscorlib.resources.dll

----------------------------------------

PS: Version is 4.6 , cause i just update it . In 4.5 the message was the same .

PS 2 : Before The Update#2 Everything working for me .
User avatar
starbuck
kill boss
Posts: 1604
Joined: Wed Jan 21, 2004 12:26 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by starbuck »

"Minge

Version de l'assembly : 1.0.0.0

Version Win32 : 1.0.0.0"

I see that. I think you are running the wrong version of Minge. You need the updated version on the first page of this thread I think.

Its the first version listed on page 1. Version 2.5.

The first version had decimal issues If I remember correctly (maybe why you get that decimal error.)

and dont worry about speaking French I understood everything you said and I can only speak English :)
User avatar
Trent
mindless
Posts: 2945
Joined: Wed Apr 05, 2000 9:08 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Trent »

Ah, the problem is with the version check. I assume it's probably related to do the culture not being set properly in the program so it uses the system's default number format when trying to parse the version string. This is a problem for systems set to use a , (comma) for the decimal point instead of a . (period).

I'll try to get version 3 out this week which will fix it. It should also stop the error happening in the current version as the version check won't have a decimal point.
a.k.a. Brent
User avatar
Steelmaniac
pedestrian
Posts: 2
Joined: Wed Jan 06, 2016 9:59 am

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Steelmaniac »

starbuck wrote:
Steelmaniac wrote:Been running into a bit of a problem when trying to launch minge. Tells me the program stopped working, even on admin mode.

Any suggestions?


I think you need NET 4.5 installed. It would also help if you posted your operating system and other details. Plus make sure you have the latest version of Minge.


Installing the latest NET version worked.

Thanks man!
User avatar
Big_pimouss
pedestrian
Posts: 24
Joined: Fri Jan 30, 2015 11:51 pm

[Tool] Minge: The CarMODgeddon Mod Installer

Post by Big_pimouss »

starbuck wrote:"Minge

Version de l'assembly : 1.0.0.0

Version Win32 : 1.0.0.0"

I see that. I think you are running the wrong version of Minge. You need the updated version on the first page of this thread I think.


Its the first version listed on page 1. Version 2.5.


The first version had decimal issues If I remember correctly (maybe why you get that decimal error.)


and dont worry about speaking French I understood everything you said and I can only speak English :)

Oh ! i don't understand , i run the version 2.5 !

Edit

Ah, the problem is with the version check. I assume it's probably related to do the culture not being set properly in the program so it uses the system's default number format when trying to parse the version string. This is a problem for systems set to use a , (comma) for the decimal point instead of a . (period).
Ok i just see that . I'll wait :D