[C2] My custom car mod crashes the game upon launching race

Discussing, modding and troubleshooting the greatest unfinished sequel ever!
User avatar
helomyname
turbo bastard
Posts: 253
Joined: Sat Dec 03, 2011 1:25 pm

[C2] My custom car mod crashes the game upon launching race

Post by helomyname »

Hello,

I've recently made a little car for C2:
Image

As far as I'm aware, I set everything up correctly using Harmalarm's 3ds max tools - all of the materials have their correct carmageddon properties set:
Image

I believe the hierarchy to be correct:
Image

To get it in the game, I created a folder called "Cyclone" in data/CARS and then i exported it using Harm's Dat Exporter.
I copied EAGLE3.TXT and renamed it to Cyclone.txt. Inside, i made sure to change the name of the car from EAGLE.TXT to Cyclone.TXT and I got rid of every funk as well.

I also removed this section from the end of the TXT

Code: Select all

3                    // Count
EADORGLL.MAT
2

SCRN2

SCRN3

EADORGLR.MAT
2

SCRN2

SCRN3

EAGLR.MAT
2

SCRN2

SCRN3

It displays in the menu correctly
Image

But the game crashes as soon as I launch a race
Image

Any idea what can be causing this crash? Tosh, i sent the files over to you if you'd like to have a look.

Hope you guys can help!
User avatar
Toshiba-3
アルカリ (単3形)
Posts: 5255
Joined: Sun Jun 08, 2003 12:14 am
Location: Bleak City

Re: [C2] My custom car mod crashes the game upon launching race

Post by Toshiba-3 »

Turns out the main issue here was a lone CAMERA_TURN_OFF_MATERIALS line at the end of the car text file without materials to hide being defined after it.
Another easy oversight found was texture filenames being too long. These filenames mustn't exceed 14 characters.
Image / carmageddon add-ons at road reaction